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Software Status Bulletin 

G3336AA Qualitative Analysis Software rev. B.06.00 SP1 
 

 

Revision Log: 

Revision Date Reason For Update 

4/5/2013 Initial revision 

  

1. Overview 
The purpose of this document is to list known problems in the software and any known workarounds or 

recovery paths.   

2. Known Problem Summary 
The following is a summary of the known problems in the software.  This is not an exhaustive list, but is a list 

of the problems a customer is most likely to encounter.   This list cross-references items in our Defect tracking 

database. 

 

Issue # Title 

172494 Manual integration of UV chromatogram with General Integrator results in strange 

baselines 

180034 Localization: In the Japanese version, "Hide any Current Empty Columns" does not 

work in the Compound List 

186897 Hitting F1 in the "Enter Filter Criteria" dialog box does not display the proper help 

page 

188285 Diff(ppm) and Diff(mDA) show incorrect values in the MS peaklist when formula 

generation results are cleared 

189804 In Accurate Mass library search, entering a ".L" or ".XML" file path in the textbox and 

trying to perform a search will throw an exception 

190451 Trying to load a data file in Qual while acquiring will flag an error 

190959 For targeted MSMS and FBF, repeated calls for extracting complete result set adds an 

MSMS spectrum 

191172 Localization: Online Help - The Japanese online help for Report Designer is not 

translated properly 

192489 Fragment formula annotation should show MFG results if best hit is neither Library ID 

hit nor Manual ID hit for user spectra 

192551 "Restore to last saved values" from file does not work for Peak absolute height 

192559 Methods fail to load after changing a "Message Box Options" dialog setting 

192601 Tab selection in the Maximum Entropy tab of Method Editor -> Find by Protein 

Deconvolution is out of order 

192609 TAB order navigation between fields is irregular in Find by Formula Options -> Result 

Filters 

192615 "Copy deconvolution settings to method" is allowed for Resolved Isotope 

Deconvolution but will crash Qual 

192958 Protein Digest matching rules field becomes blank and rules become unavailable for 

selection upon certain actions 

193050 Selecting multiple compounds in the Data Navigator pane will not include the first 

compound selected 
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193063 Changing the "Source of formulas to confirm" in the Formula Source tab of FbF - 

Options also adds a blue triangle to the "Find by Formula - Chromatograms" section in 

Method Explorer 

193065 "Create Compound from Highlighted Range on Deconvoluted Spectrum" is not 

supported for Isotope Resolved Deconvoluted spectra and will cause crashes 

193067 The LMFE tab is not greyed out when "small molecule" is selected for "Target data 

type" in the method editor 

193228 Once the Compare Protein Digest Files wizard process starts it cannot be canceled. 

193229 Message needs to be displayed before the process completes 

193338 "Protease digest location" indicators are removed after canceling the Edit Digest 

Reagents dialog 

193339 Digest List: Define and Match Sequence pane loses data 

193378 An error message found in: Method Editor > Find Compound by Formula - Options > 

Positive Ions tab, is not translated into Chinese 

193470 Changing back to the default printer does not work for deconvolution results 

193486 Occasional exception flags when changing workflows using data files not in the 

customer's Home path 

193489 Compound list table print-out is illegible for some settings 

193630 Function: changed value messages are missing in Method Editor > Find Compound by 

Formula - Options > Results tab 

193718 No blue triangles are added to the method editor for search accurate mass library when 

switching search accurate mass library to search unit mass library 

193755 Find by Integration -> Adjust Delay Time tab contains misaligned fields 

194031 Localization Issue: Error message contains both English and Japanese strings 

194053 Displaying overlaid MRMs then switching from minutes to scans may cause an error 

194449 All Ions MS/MS (AIM) - Visualization in the Compound Fragment Spectrum Results 

window in Compound Details View (CDV) is incorrect 

194537 Cell borders are missing in BioConfirm Protein Compound reports 

194539 Oligonucleotide reports will contain some cosmetic discrepancies 

194702 Localization: "Acquisition Time" axis label in the Chromatogram Result plot is not 

translated into Japanese 

194817 Scrolling anomaly exists in Digest Comparative Analysis window 

194818 Multiple rows cannot be highlighted in Compound Compare List table 

194819 Chromatogram selection in Digest Compare Results does not work correctly 

194820 Chromatogram Compare report generation does not work properly 

194821 Mass Spectrum Compare Results printing has several issues 

194822 MSMS Spectrum Compare Results pane has multiple print issues 

195162 F1 doesn't show help in Isotope Distribution Calculator 

195492 In CDV with BioConfirm ProteinDigest results - scrolling to the end of the Compound 

List then back up to last seq. match will cause the cursor to slowly self scroll back to 

end of list/last compound 

195643 Layouts in Compound Details View (CDV) and Navigator View (NV) do not save and 

preserve which PANE is on top if multiple windows are TABBED. 

195649 Changing workflows does not work if "Save current method" is checked in the dialog 

box 

195773 EIC Peak List table does not get updated in tandem with compound selection 

195933 If only "Other (CE)" is marked in the User Interface Configuration dialog box, menu 

items and method editor sections are not chosen consistently 

196295 Exception occurs in METLIN - Navigator View while repeatedly printing reports over 

and over for thousands of compounds per data file 
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196296 Exception on generating Compound Report for ForensicsTox Find by Formula analysis 

196507 Color coding of ions based on Fragment Annotation is still displayed when Fragment 

Annotation is unchecked. 

196599 All Ions: ?? appearing on "delete" and "extract complete result set" 

196720 MS/MS Formula details disappear when selecting a different "Best" Formula after 

running Find Compounds by Auto MS/MS and MFG 

196721 The "Hide Empty Columns" tool button in the Compound List works for the first level, 

but not the second level. 

196722 Compound List column order for BioConfirm Protein Digest is randomly ordered 

196831 In Compound Details View, right-clicking near an axis in the Compound 

Chromatogram window will throw an error 

196842 Merged Spectrum ID Results with LibSearch-MFG results - only the highest Lib Score 

hit has MFG results and Isotope pattern although all are labeled as merged LibSearch-

MFG 

196930 Spectrum not seen on printed report when grid lines are turned on. 

196936 A Compound report after running MFE + MFG contains 3 columns with the identical 

formula 

196939 When run as a Compound Automation Step, Find Compounds by MRM produces a 

TIC Scan with NO DATA POINTS 

197052 Qual crashes when Find by Protein Deconvolution is attempted under specific 

conditions 

197054 Protein compound report with two data sets may fail 

197064 Compound Details View (CDV) - Exception when trying to access the Add/Remove 

Columns dialog in the 4th level of the Compound ID Results Window 

197212 Tooltip of Method Explorer is not properly updated 

197263 Annotation does not work properly for a HighE spectrum 

197273 Formula and Mass Calculators do not contain GC/Q-TOF parameters when a GC/Q-

TOF method is loaded 

197404 Chemical Data Dictionary Editor tabs do not display the relevant help topics 

197514 Wizard pages do not display relevant help topics 

  

3. Known Problems Detailed Description 
The following is the detailed descriptions of the known problems in the Qualitative Analysis software.  This 

section includes more extensive information from our defect tracking database.  This section also includes any 

known workarounds or recovery paths 

 

Issue # 172494 

 

Title Manual integration of UV chromatogram with General Integrator results in strange 

baselines 

Description When the user manually integrates a UV chromatogram with the General integrator, it 

creates very strange baselines.     

 

The problem only appears to happen on peaks with an RT > 6 minutes.  If you 

manually integrate the peaks before 6 minutes, it works fine. 

 

 

Issue # 180034 
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Title Localization: In the Japanese version, "Hide any Current Empty Columns" does not 

work in the Compound List 

Description 1. Load sulfa-posESIautoMSMS-c.d  

2. Method Editor > Find Compound by Formula > Formula Source tab 

3. Select Database & mass(e) 

4. Run Find Compounds by Formula 

5. Show Compound list and Compound Identification Result 

6. Select "Hide any current Empty Column" to hide empty columns. 

 

Does not work in Compound List view or Compound Identification Results views. 

 

Note: This applies to the Japanese version. 

 

Issue # 186897 

 

Title Hitting F1 in the "Enter Filter Criteria" dialog box does not display the proper help 

page 

Description Pressing F1 in the "Enter Filter Criteria" dialog box will display the main help page 

instead of the proper topic's page. 

 

 

Issue # 188285 

 

Title Diff(ppm) and Diff(mDA) show incorrect values in the MS peaklist when formula 

generation results are cleared. 

Description Generate formula for a spectrum. 

Some rows with Diff(ppm) and Diff(mDA) in the MS peak list table there will contain 

gibberish.  

Clearing the spectrum identification results will then result in the MS peak list table 

containing many rows of "Diff(ppm)" and "Diff(mDA)" filled with gibberish. 

 

Issue # 189804 

 

Title In Accurate Mass library search, entering a ".L" or ".XML" file path in the textbox and trying to 

perform a search will throw an exception 

Descrip

tion 

1. Open a datafile (eg: _2_1CP_2^2_25_F.D) 

2. Perform "Find Compounds by Chromatogram Deconvolution" 

3. Select the compounds and go to Method Explorer -> Identify Compounds -> Search Accurate 

Mass Library 

4. Enter a .L library path (eg: C:\DATABASE\NIST08.L) in the textbox manually (without 

browsing) and click "Search Library for Compounds". 

 

The following exception is thrown: 

 

"Program: Agilent MassHunter Workstation Software Qualitative Analysis B.06.00 

Build Configuration: Release 

Message: Object reference not set to an instance of an object. 

Stack Trace:  

Server stack trace:  

   at Agilent.MassSpectrometry.DataAnalysis.UnitMassSearch.DoSearch(ICompound iCpd, 

IMassSpectrum iMsSpec, IUnitsConverter iUnitsConverter, Double appDelayTime, 
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ILibrarySearchSettings libSearchSettings) in 

z:\Archer\core\CoreSpectralLibrarySearch\SpectralLibrarySearch\Algorithms\UnitMassSearch.cs:lin

e 59 

   at 

Agilent.MassSpectrometry.DataAnalysis.SpectralLibrarySearch.Agilent.MassSpectrometry.DataAna

lysis.ISpectralLibrarySearch.Search(ICompound compound, ISpectrum spectrum, 

ILibrarySearchSettings searchSettings) in 

z:\Archer\core\CoreSpectralLibrarySearch\SpectralLibrarySearch\Algorithms\SpectralLibrarySearch

.cs:line 307 

   at 

Agilent.MassSpectrometry.DataAnalysis.Qualitative.QualCommandBase.LibSearchForCompoundS

pec(ISpectralLibrarySearch libSearch, ILibrarySearchSettings searchSettings, DataItem 

cpdDataItem, DataItem[] specDataItem) 

   at 

Agilent.MassSpectrometry.DataAnalysis.Qualitative.QualCommandBase.DoCpdLibrarySearch(Data

Item[] selectedItems, LimitProgressTracker overallProgress) 

   at 

Agilent.MassSpectrometry.DataAnalysis.Qualitative.CmdLibaraySearchCompound.DoSpecialized() 

   at Agilent.MassSpectrometry.DataAnalysis.Qualitative.CmdApply.DoSpecialized() 

   at Agilent.MassSpectrometry.DataAnalysis.Qualitative.QualCommandBase.Do() 

   at Agilent.MassSpectrometry.CommandModel.CommandHistory.Invoke(ICommand cmd) in 

z:\Archer\core\Command\commandmodel\commandhistory.cs:line 337 

   at System.Runtime.Remoting.Messaging.StackBuilderSink._PrivateProcessMessage(IntPtr md, 

Object[] args, Object server, Int32 methodPtr, Boolean fExecuteInContext, Object[]& outArgs) 

   at 

System.Runtime.Remoting.Messaging.StackBuilderSink.PrivateProcessMessage(RuntimeMethodHa

ndle md, Object[] args, Object server, Int32 methodPtr, Boolean fExecuteInContext, Object[]& 

outArgs) 

   at System.Runtime.Remoting.Messaging.StackBuilderSink.AsyncProcessMessage(IMessage msg, 

IMessageSink replySink) 

 

Exception rethrown at [0]:  

   at System.Runtime.Remoting.Proxies.RealProxy.EndInvokeHelper(Message reqMsg, Boolean 

bProxyCase) 

   at System.Runtime.Remoting.Proxies.RemotingProxy.Invoke(Object NotUsed, MessageData& 

msgData) 

   at 

Agilent.MassSpectrometry.CommandModel.CommandHistory.InvokeCommand.EndInvoke(IAsync

Result result) 

   at Agilent.MassSpectrometry.DataAnalysis.Qualitative.AppManager.EndInvoke(IAsyncResult 

result) 

   at 

Agilent.MassSpectrometry.DataAnalysis.Qualitative.QualForm.OnAsyncCallBack(IAsyncResult 

asyncResult) in z:\Archer\qual\presentation\AgtQual\QualFormP1.cs:line 2369" 

 

Issue # 190451 

 

Title Trying to load a data file in Qual while acquiring will flag an error 

Description If a dMRM or tMRM data file is loaded into qual while it is simultaneously being 

acquired, an exception will be thrown 
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Issue # 190959 

 

Title For targeted MSMS and FBF, repeated calls for extracting complete result set adds an 

MSMS spectrum 

Description 1) Open sulfas_PosTargetedMSMS.d 

2) Load default.m. 

3) Run find compounds by targeted MSMS. 

4) Each compound will have a TIC and Product ion scan extracted. 

5) Run extract complete result set: a MS scan and Product ion scan is added.  

6) Run extract complete result set again: another Product ion scan (same as previous) is 

added.  

 

This also happens with FbF. 

 

Issue # 191172 

 

Title Localization: Online help file Index is all gibberish and cannot be searched in Japanese 

Description Online help Index tab is all gibberish. 

Additionally, cannot search in Japanese with search tab. 

 

Issue # 192489 

 

Title Fragment formula annotation should show MFG results if best hit is neither Library ID 

hit nor Manual ID hit for user spectra 

Description 1) For a user spectra that has a library (and/or manual id) id, MFG, or database search 

results. 

2) Check fragment formula annotation.  

3) If the "best" hit is among library id or manual id then FFA (fragment formula 

annotation) should be executed and the spectra should be colored accordingly 

4) However, if the user selects MFG or Dbase ID as "best" hit then peaks that should be 

labelled with MFG results are not labeled properly (if it is calculated for that spectra).  

 

-Additionally, any Red or Green labeled peaks do not revert to a single color. 

 

Issue # 192551 

 

Title "Restore to last saved values" from file does not work for Peak absolute height 

Description 1) Load default.m or any other method  

2) Open: Method Editor - Deconvolute (MS): Protein.  

3) In the Maximum Entropy tab select "Peak absolute height." 

4) Click on the "Restore to last saved values from file" icon in the method editor 

toolbar. 

 

The radio button will not change back to the "Peak signal-to-noise" parameter. 

 

Issue # 192559 

 

Title Methods fail to load after changing a "Message Box Options" dialog setting 

Description 1) Close any exisiting data file.  

2) Ensure Method check box is not marked in Configuration -> Message Box Options.  

3) Open the previously closed data file with "Load results method" selected.   
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4) In the Save dialog (for method changes) that is displayed select both check boxes: 

"Save as needed" and "Do not show this box again"  

5) Click No.  

6) Click on the "Open Method" icon in the Find by Protein Method Editor.  

7) In the Open Method dialog box, select a user created method and click Open.  

8) In the Save Method dialog box, rename the file and save the method.  The new 

method name will be displayed in the title bar.  

 

9) Click on the Open Method icon in the Find by Protein method editor. 

10) Select another method and click Open.   

 

The selected method will not load.  

Subsequent attempts will also fail and Qual will have to be forced out via the Task 

Manager. 

 

Issue # 192601 

 

Title Tab selection in the Maximum Entropy tab of Method Editor -> Find by Protein 

Deconvolution is out of order 

Description 1) Method Editor -> Find by Protein Deconvolution and proceed to the Maximum 

Entropy tab. 

2) Whilst using the tab key to change fields,  after "Limit to the largest parameter", the 

tab selection leaves the Method Editor before continuing with the rest of the fields. 

 

Issue # 192609 

 

Title TAB order navigation between fields is irregular in Find by Formula Options -> Result 

Filters 

Description For any TOF datafile: the TAB order navigation between fields is irregular in Find by 

Formula Options -> Result Filters 

 

-If the user enters a new valid value for Warn if score is < _______,  hittnig the TAB 

key highlights the text description for the checkbox at the bottom of the pane "Do not 

match if the (unobserved" second ions abundance is expected to be > _______." instead 

of the actual field. 

 

-Hitting the TAB key highlights the text for the first checkbox in the pane "Only 

generate Compounds to matched formulas" and not the actual field. 

 

Issue # 192615 

 

Title "Copy deconvolution settings to method" is allowed for Resolved Isotope 

Deconvolution but will crash Qual 

Description "Copy deconvolution settings to method" is intended for Peak Modeling Deconvolution 

and Max Entropy Deconvolution.  Trying to use this on Resolved Isotope 

Deconvolution will crash Qual. 

 

Issue # 192958 

 

Title Protein Digest matching rules field becomes blank and rules become unavailable for 

selection upon certain actions 
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Description 1) Load enolase digest data (or any other digest data file).  

2) Open Sequence -> Edit matching rules.  

3) Use the Ctrl key deselect all the matching rules and click OK or Cancel.   

 

When the dialog is re-opened, all the rules are removed and are also not available for 

selection.  

This happens with Protein matching rules as well. 

 

Issue # 193050 

 

Title Selecting multiple compounds in the Data Navigator pane will not include the first 

compound selected. 

Description 1) In Navigator View, highlight the first compound. 

2) Hold shift key and clicke the fourth compound in the list in the Data Navigator 

window. 

3) Instead of compounds 1 – 4 being highlighted, only compounds 2 – 4 are 

highlighted.  

      

If compounds 2-4 are selected, only compounds 3 and 4 are highlighted. 

 

 

Issue # 193063 

 

Title Changing the "Source of formulas to confirm" in the Formula Source tab of FbF - 

Options also adds a blue triangle to the "Find by Formula - Chromatograms" section in 

Method Explorer 

Description Changing the "Source of Formulas to Confirm" in the Formula Source tab of FbF - 

Options will also add a blue triangle to the "FbF - Chromatograms" section in the 

Method Explorer pane. 

 

This does not impact usability. 

 

Issue # 193065 

 

Title "Create Compound from Highlighted Range on Deconvoluted Spectrum" is not 

supported for Isotope Resolved Deconvoluted spectra and will cause crashes 

Description -Find > Create Compound from Highlighted Range on Deconvoluted Spectrum > Add 

Highest Peak will throw: “Qualitative Analysis encountered an error” message. 

 

Temporary Solution:  
This is not a supported feature for RID. 

 

Fix Information:  
This option for RID will be disabled in future. 

 

Issue # 193067 

 

Title The LMFE tab is not greyed out when "small molecule" is selected for "Target data 

type" in the method editor 

Description LMFE tab is still editable when small molecule items are selected for "Target data 

type" in the method editor. 
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Issue # 193228 

 

Title Once the Compare Protein DigestFiles wizard process starts it cannot be canceled. 

Description 1) Open enolase digest chip data files.  

2) Open: Compare Protein Digest Files -> Find Results, Identify and Compare.  

3) Load the data files in the first page of the wizard and click Finish.   

 

After it starts, click on the Cancel button in the progress dialog. The run does not end 

and the user has to wait for it to complete.  Can take up to 30 mins or longer with more 

than 2 data files. 

 

Issue # 193229 

 

Title Message needs to be displayed before the process completes 

Description 1) Open enolase digest chip data files.  

2) Open: Compare Protein Digest Files -> Find Results, Identify and Compare.  

3) Load the data files in the first page of the wizard.   

4) Ensure that there is no sequence file or mass list in the Define and Match Sequence 

page of wizard. 

5) Click Finish.  

 

 The message "Match Operation was not started. Please enter a sequence in the Match 

Sequences..." appears at the end of the process, instead right after the Finish button is 

clicked. 

 

 

 

Issue # 193338 

 

Title "Protease digest location" indicators are removed after canceling the Edit Digest 

Reagents dialog 

Description 1) Import any digest sequence file into the Sequence editor.   

2) Using the right-click context menu, open “Edit Digest Reagents”.  Click OK.   

3) The digest markings are placed in the sequence.   

4) Re-open the dialog and add another reagent from “Available” to “Select” field. Click 

Cancel.  

 

 All the previous digest markings are removed. 

 

Issue # 193339 

 

Title Digest List: Define and Match Sequence pane loses data 

Description Digest List: Define and Match Sequence pane loses data after Clicking OK in the Edit 

Digest Reagents dialog. After that it does not get updated if a change is made to the 

sequence.  

 

The same thing occurs in the Edit Modifications dialog. 

 

Issue # 193378 
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Title An error message found in: Method Editor > Find Compound by Formula - Options > 

Positive Ions tab, is not translated into Chinese 

Description The error message in the mentioned tab states: "Ranges must be ordered (minimum - 

maximum)." 

It is not translated into Chinese like the rest of the dialog box. 

 

Issue # 193470 

 

Title Changing back to the default printer does not work for deconvolution results 

Description 1) Configure the computer with at least two printers. 

2) Load a data file with deconvolution results.  

3) Right click in the results pane and select Print. Printing with the default printer 

properly sends to the default printer.  

4) Change the printer name field to a second printer in the Print dialog and click OK.  

This properly sends to the second printer.  

5) Reopen the print dialog and change the Printer name field back to default and click 

OK.   

 

This will not properly send to the default printer.  Instead, the second printer is still 

used. 

 

Issue # 193486 

 

Title Occasional exception flags when changing workflows using data files not in the customer's Home 

path 

Descri

ption 

1) Configure User Interface for GC-QTOF 

2) Load TOF type file such as MSD_mix_4stds_DG_spl200_03.D 

3) Use General or GC-QTOF workflow 

4) Run Find by Integration 

5) Run a library search with: "demo.L" 

6) Save results 

7) Configure General Workflow.  

 

- Clicking OK MAY then cause Qual to crash with the following exception: 

 

Date and Time: 8/28/2012  9:55 AM 

Program: Agilent MassHunter Workstation Software Qualitative Analysis B.06.00 

Build Configuration: Release 

Message: Error creating window handle. 

Stack Trace:    at System.Windows.Forms.NativeWindow.CreateHandle(CreateParams cp) 

   at System.Windows.Forms.Control.CreateHandle() 

   at System.Windows.Forms.Control.CreateControl(Boolean fIgnoreVisible) 

   at System.Windows.Forms.Control.CreateControl() 

   at System.Windows.Forms.Control.OnVisibleChanged(EventArgs e) 

   at System.Windows.Forms.Control.OnVisibleChanged(EventArgs e) 

   at System.Windows.Forms.Form.OnVisibleChanged(EventArgs e) 

   at System.Windows.Forms.Control.SetVisibleCore(Boolean value) 

   at System.Windows.Forms.Form.SetVisibleCore(Boolean value) 

   at System.Windows.Forms.Application.ThreadContext.RunMessageLoopInner(Int32 reason, 

ApplicationContext context) 

   at System.Windows.Forms.Application.ThreadContext.RunMessageLoop(Int32 reason, 
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ApplicationContext context) 

   at System.Windows.Forms.Form.ShowDialog(IWin32Window owner) 

   at Agilent.MassSpectrometry.DataAnalysis.BaseErrorDialog.ShowException(Exception exception) 

   at 

Agilent.MassSpectrometry.DataAnalysis.Qualitative.QualForm.OnQualFormThreadExceptionEvent(

Object sender, ThreadExceptionEventArgs e) 

   at System.Windows.Forms.Application.ThreadContext.OnThreadException(Exception t) 

   at System.Windows.Forms.NativeWindow.Callback(IntPtr hWnd, Int32 msg, IntPtr wparam, IntPtr 

lparam) 

   at System.Windows.Forms.UnsafeNativeMethods.DispatchMessageW(MSG& msg) 

   at 

System.Windows.Forms.Application.ComponentManager.System.Windows.Forms.UnsafeNativeMet

hods.IMsoComponentManager.FPushMessageLoop(IntPtr dwComponentID, Int32 reason, Int32 

pvLoopData) 

   at System.Windows.Forms.Application.ThreadContext.RunMessageLoopInner(Int32 reason, 

ApplicationContext context) 

   at System.Windows.Forms.Application.ThreadContext.RunMessageLoop(Int32 reason, 

ApplicationContext context) 

   at Agilent.MassSpectrometry.DataAnalysis.Qualitative.Program.Main(String[] args) 

 

Issue # 193489 

 

Title Compound list table print-out is illegible for some settings 

Description 1) Load a data file (ie - serotransferrin.d) with mass match results for about 75 

compounds. (Limit to 75 compounds in the Find by MFE editor).  

2) Configure the Compound List table to have 8-10 columns. 

3) Right click in the Compound list pane and select Print command. 

4) Select All rows in the Print dialog.  

5) In the Options tab of the dialog select "Fit to one page" and landscape orientation.  

Click OK. 

 

The printed spectra is confined to a narrow space on the left hand side of the page and 

is illegible.  Much of the page will be empty.  

Two pages may be printed instead of one. 

 

Issue # 193630 

 

Title Function: changed value messages are missing in Method Editor > Find Compound by 

Formula - Options > Results tab 

Description 1) Select Find compounds by Formula > Find Compounds by Formula -Options in 

method explorer 

2) Open Results tab. 

3) Enable Extract raw spectrum option 

4) Enable Clip extracted raw spectra  option 

5) Select Asymmetric (m/z) from dropdown 

6) Enter valid values for both input box (such as 6 and 11) 

 

Changed value blue triangles with a message should be displayed. 

Currently, nothing appears there. 

 

Issue # 193718 
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Title No blue triangles are added to the method editor for search accurate mass library when 

switching search accurate mass library to search unit mass library 

Description Adding a library to the Library selection list in the Search Unit Mass Library > Library 

Search section will also add a blue triangleto the Search Accurate Mass library line in 

the Method Explorer. 

 

This has no impact on usability. 

 

Issue # 193755 

 

Title Find by Integration -> Adjust Delay Time tab contains misaligned fields 

Description The headings under: 'Method Editor -> Find by Integration -> Adjust Delay Time' are 

slightly misaligned. 

Will not affect usability or legibility 

 

Issue # 194031 

 

Title Localization Issue: Error message contains both English and Japanese strings 

Description Trying to print an acquisition report with data without a method file will gnerate an 

error that contains English and Japanese strings. 

 

Issue # 194053 

 

Title Displaying overlaid MRMs then switching from minutes to scans may cause an error 

Description Loading a few MRM files, overlaying them, and then switching from minutes to scans 

may intermittenly throw an exception. 

 

This error is non-fatal and the user may still proceed. 

 

Issue # 194449 

 

Title All Ions MS/MS (AIM) - Visualization in the Compound Fragment Spectrum Results 

window in Compound Details View (CDV) is incorrect 

Description a) The default zoom range in the x-axis is currently not limited, for target compounds, 

to the mass of the highest selected adduct species multiplied by the charge state plus 20. 

b) The red isotopic pattern boxes are incorrectly drawn with a factor of 20 too high. 

 

Issue # 194537 

 

Title Cell borders are missing in Bioconfirm Protein Compound reports 

Description When printing data files with protein deconvolution results to the compound report 

template, BioConfirmProteinCompoundReport.xltx, all columns after MaxZ are 

missing the cell borders. 

 

Issue # 194539 

 

Title Oligonucleotide reports will contain some cosmetic discrepancies 

Description 1) Select BioConfirmOligonucleotideCompoundReport.xltx in Common Reporting 

Options.   
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2) Load any data file with oligonucleotide results.   

3) File -> Print a compound report.  

 

1. The cell borders are missing for all columns after Vol column. 

2. The x-axes of EICs and ECCs have overlapping text. 

 

This is cosmetic and has no impact on usability or stability. 

 

Issue # 194702 

 

Title Localization: "Acquisition Time" axis label in the Chromatogram Result plot is not 

translated into Japanese 

Description Loading a data file processed in English into the Japanese version of Qual will not have 

"Acquistion Time" in the x-axis of a Chromatogram Results plot translated into 

Japanese properly. 

 

This is cosmetic and has no impact on usability or stability. 

 

Issue # 194817 

 

Title Scrolling anomaly exists in Digest Comparative Analysis window 

Description 1) Open two digest data files (for example enolase digest).  

2) Select Wizards | Compare Digest Files : Find results...   

3) Iimport the corresponding sequence file in the Define Match Sequences page.  

4) Complete the rest of the wizard and generate results.   

 

In the Comparative analysis window that gets displayed, scroll down Compound 

Compare List and highlight a row.   

The scroll position square jumps up to the top and does not stay at the selected position. 

 

Issue # 194818 

 

Title Multiple rows cannot be highlighted in Compound Compare List table 

Description 1) Open two digest data files (for example enolase digest).  

2) Select Wizards | Compare Digest Files : Find results...  

3) Iimport the corresponding sequence file in the Define Match Sequences page.  

4) Complete the rest of the wizard and generate results.   

 

In the Comparative analysis window that gets displayed, highlight a row in Compound 

Compare List and use the shift key to highlight multiple rows. 

The user is then unable to highlight the multiple rows. 

 

Issue # 194819 

 

Title Chromatogram selection in Digest Compare Results does not work correctly 

Description 1) Open two digest data files (for example enolase digest). 

2) Select Wizards | Compare Digest Files : Find results...  

3) Importi the corresponding sequence file in the Define Match Sequences page.  

4) Complete the rest of the wizard and generate results.   

5) In the Comparative analysis window do the following actions: 
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-With Extracted Compound Chromatogram (ECC's) displayed click inside the 

Chromatogram Compare Results pane in Comparative Analysis results.  -Select Total 

Ion or Total Compound Chromatogram.  

-Reselecting Extraction compound or Extracted ion chromatogram will not display the 

selected chromatogram. It will still display either: Total Ion or Total Compound 

Chromatogram. 

 

Issue # 194820 

 

Title Chromatogram Compare report generation does not work properly 

Description 1) Open two digest data files (for example enolase digest).  

2) Select Wizards | Compare Digest Files : Find results...  

3) Import the corresponding sequence file in the Define Match Sequences page.  

4) Complete the rest of the wizard and generate results.   

 

5) In the Comparative analysis window that gets displayed, perform the following 

actions: 

  -Click on any row in the Compare List table.  

  -Click on the Print icon in Chromatogram Compare Results pane.  

  -Select "All chromatograms" radio button in the Print dialog and click OK.   

  -Two different rows are printed even though only one row was selected.   

  -Select another row and repeat the process.   

 

  -The selected row is printed in addition to the previously selected rows.   

This acts as if CTRL key was used in the table. 

 

Issue # 194821 

 

Title Mass Spectrum Compare Results printing has several issues 

Description 1) Open two digest data files (for example enolase digest). 

2) Select Wizards | Compare Digest Files : Find results...   

3) Import the corresponding sequence file in the Define Match Sequences page. 

4) Complete the rest of the wizard and generate results.   

 

In the Comparative analysis window that gets displayed perform the following actions: 

5) Click on any row in the Compare List table.   

6) Click on the Print icon in Mass Spectrum Compare Results pane.  

7) Select "All spectra" radio button in the Print dialog and click OK.   

 

Two different rows are printed even though only one row is selected.   

Select another row and repeat the process.   

The selected row is printed in addition to the previously selected rows.  This acts as if 

CTRL key was used in the table. 

 

-Additionally, when the mass spectrum is the chosen in the combo box of the pane, 

MFE manufactured spectra are not included. Product ion spectra are included instead, 

which should not be part of this pane.  

 

-Finally, Header and footer information are not given. 

 

Issue # 194822 
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Title MSMS Spectrum Compare Results pane has multiple print issues 

Description 1) Open two digest data files (for example enolase digest). 

2) Select Wizards | Compare Digest Files : Find results...  

3) Import the corresponding sequence file in the Define Match Sequences page. 

4) Complete the rest of the wizard and generate results.   

 

In the Comparative analysis window that gets displayed perform the following actions: 

5) Click on any row in the Compare List table.   

6) Click on the Print icon in MSMS Spectrum Compare Results pane. 

7) Select the "All spectra" radio button in the Print dialog and click OK.   

 

Two different rows are printed even though only one row is selected.   

Select another row and repeat the process.   

 

The selected row is printed in addition to the previously selected rows.  This acts as if 

CTRL key was used in the table. 

 

-Additionally, "Scan Spectra MFE" manufactured spectra are included, which should 

not be part of this pane.  

-Finally, Header and footer information are not given.. 

 

Issue # 195162 

 

Title F1 doesn't show help in Isotope Distribution Calculator 

Description Pressing F1 in the Isotope Distribution Calculator will not display the help screen. 

The user will need to manually mouse to the "Help" menu option. 

 

Issue # 195492 

 

Title In CDV with BioConfirm ProteinDigest results - scrolling to the end of the Compound 

List then back up to last seq. match will cause the cursor to slowly self scroll back to 

end of list/last compound 

Description 1) Opn Datafile: enolase-Chip-final.D 

2) Load EnolaseMSMS.m if available; if not use BCProteinDigest default method 

3) Run MFE - TheEnolase method contains the Enolase sequence 

If not available load BSADigest.psq or any available sequence file  

 

4) Run Match Sequence. 

5) Switch to CDV (Compound Details View) 

6) View->Sequence Coverage Map  

7) Proceed to Compound ID Results pane 

8) Select another row in Compound List 

 

The Win7 busy icon (turquoise circle) will appear and the cursor will constantly move 

from row to row endlessly. 

 

Issue # 195643 

 

Title Layouts in Compound Details View (CDV) and Navigator View (NV) do not save and 

preserve which PANE is on top if multiple windows are TABBED 
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Description 1) In Navigator View, have the Compound List and the Peak List tabbed at the top, with 

the Compound List in front.  

2) Save the layout, switch to CDV and back to NV 

 

The Peak List is now in front. After running the MFE algorithm, there are no results in 

the peak list. 

 

1) In Compound Details View, display the "Overall Chromatogram Results" window 

tabbed behind the "Compound Chromatogram Results" window. 

2) Switch back and forth between CDV and NV will cause the "Overall Chromatogram 

Results window to come to the front. 

 

Issue # 195649 

 

Title Changing workflows does not work if "Save current method" is checked in the dialog 

box 

Description Normally, when changing workflows, a dialog comes up.  

If "Save current method" is checked in that dialog box, no layout change happens. 

 

Issue # 195773 

 

Title EIC Peak List table does not get updated in tandem with compound selection 

Description 1) Enter 10-20k for the mass range In the Find by Protein Deconvolution method editor.  

2) Select TIC and Extract EIC in the results tab.   

3) Run Find by Protein Deconvolution for BetaLac.d.  

4) Highlight the compounds in the compound list table one at a time.  

 

-The MS Peaks Two table does not always gets updated to correspond to the 

highlighted compound. 

 

This will not impact usability or stability. 

 

Issue # 195933 

 

Title If only "Other (CE)" is marked in the User Interface Configuration dialog box, menu 

items and method editor sections are not chosen consistently 

Description Mark ONLY "Other (CE)" in the User Interface Configuration dialog box for the 

separation type. 

 

1) “Find by Targeted MS/MS” algorithm is available in the Method Explorer, but is not 

listed in the “Find” menu. 

2) In the Method Explorer, the only “Identify Compounds” section that is available is 

“Combine Identification Results”.  

However, in the “Compound Automation Steps” section, all of the Compound 

identification algorithms can be marked. 

3) Database Search tabs and the Generate Formulas tabs in the Chromatogram Peak 

Survey Workflow are also accessible.  (but not in the Identify section of the method 

editor) 

4) In the "Identify" menu, the menu item “Search Library for Spectra” is available, but 

the selected library cannot be changed because those sections are not available in the 

"Identify" section of the Method Editor. 
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Issue # 196295 

 

Title Exception occurs in Metlin - Navigator View while repeatedly printing reports over and over for 

thousands of compounds per data file 

Descripti

on 

The following exception will flag in this case: 

 

Program: Agilent MassHunter Workstation Software Qualitative Analysis B.06.00 

Build Configuration: Release 

Message: Following exception occured  while exceuting script -  

Error creating window handle. 

 

At- 

   at System.Windows.Forms.NativeWindow.CreateHandle(CreateParams cp) 

   at System.Windows.Forms.Control.CreateHandle() 

   at System.Windows.Forms.Control.get_Handle() 

   at System.Windows.Forms.Control.CreateGraphicsInternal() 

   at System.Windows.Forms.Control.CreateGraphics() 

   at 

Agilent.MassSpectrometry.DataAnalysis.Qualitative.BaseReportGenerator.WritePlotImageToFile(I

AppState appState, ExportedImageType imageType, UIUpdateDisplayPlotControlBase 

plotControl, Double heightByWidthRatio, String imageFilename) 

   at 

Agilent.MassSpectrometry.DataAnalysis.Qualitative.BaseReportGenerator.CreatePlotImageFile(ID

ataItem plotItem, ExportedImageType imageType, Boolean overlayPredictionPattern, IRange 

XZoomRange, Double heightByWidthRatio, Boolean allowZoom) 

   at 

Agilent.MassSpectrometry.DataAnalysis.Qualitative.BaseReportGenerator.WritePlotPairs(IDataIte

m[] plots, Int32 ItemID) 

   at 

Agilent.MassSpectrometry.DataAnalysis.Qualitative.CompoundReportGenerator.WriteCompound

Chromatograms(IDataItem plotItem, List`1 cpdChildren, Boolean& hasAllIonsResults) 

   at 

Agilent.MassSpectrometry.DataAnalysis.Qualitative.CompoundReportGenerator.WriteCompounds

(IDataItem[] compounds) 

   at 

Agilent.MassSpectrometry.DataAnalysis.Qualitative.CompoundReportGenerator.GenerateReportS

pecialized(IDataItem[] selectedAnalysis) 

   at 

Agilent.MassSpectrometry.DataAnalysis.Qualitative.BaseReportGenerator.GenerateReportAndMa

pExceptions(IDataItem[] analyses) 

   at 

Agilent.MassSpectrometry.DataAnalysis.Qualitative.BaseReportGenerator.GenerateReport(IDataIt

em[] selectedAnalysis) 

   at Agilent.MassSpectrometry.DataAnalysis.Qualitative.CmdGenerateReport.DoSpecialized() 

   at Agilent.MassSpectrometry.DataAnalysis.Qualitative.QualCommandBase.Do() 

   at Agilent.MassSpectrometry.CommandModel.CommandHistory.Invoke(ICommand cmd) 

   at Agilent.MassSpectrometry.DataAnalysis.Qualitative.AppManager.Invoke(ICommand cmd) 

Stack Trace:  

Server stack trace:  

   at Agilent.MassSpectrometry.DataAnalysis.Qualitative.AppManager.BeginRun(String 
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assemblyPath, QualScriptEnvironment qualScriptEnvironment) 

   at Agilent.MassSpectrometry.DataAnalysis.Qualitative.QualCommandBase.RunScript(String 

script, QualScriptParameters scriptParams, ActionItemCollection actions) 

   at Agilent.MassSpectrometry.DataAnalysis.Qualitative.QualCommandBase.RunScripts(String[] 

scripts, QualScriptParameters scriptParams, ActionItemCollection actions) 

   at Agilent.MassSpectrometry.DataAnalysis.Qualitative.CmdRunScript.DoSpecialized() 

   at Agilent.MassSpectrometry.DataAnalysis.Qualitative.CmdApply.DoSpecialized() 

   at Agilent.MassSpectrometry.DataAnalysis.Qualitative.QualCommandBase.Do() 

   at Agilent.MassSpectrometry.CommandModel.CommandHistory.Invoke(ICommand cmd) 

   at System.Runtime.Remoting.Messaging.StackBuilderSink._PrivateProcessMessage(IntPtr md, 

Object[] args, Object server, Int32 methodPtr, Boolean fExecuteInContext, Object[]& outArgs) 

   at 

System.Runtime.Remoting.Messaging.StackBuilderSink.PrivateProcessMessage(RuntimeMethodH

andle md, Object[] args, Object server, Int32 methodPtr, Boolean fExecuteInContext, Object[]& 

outArgs) 

   at System.Runtime.Remoting.Messaging.StackBuilderSink.AsyncProcessMessage(IMessage 

msg, IMessageSink replySink) 

 

Exception rethrown at [0]:  

   at System.Runtime.Remoting.Proxies.RealProxy.EndInvokeHelper(Message reqMsg, Boolean 

bProxyCase) 

   at System.Runtime.Remoting.Proxies.RemotingProxy.Invoke(Object NotUsed, MessageData& 

msgData) 

   at 

Agilent.MassSpectrometry.CommandModel.CommandHistory.InvokeCommand.EndInvoke(IAsyn

cResult result) 

   at Agilent.MassSpectrometry.DataAnalysis.Qualitative.AppManager.EndInvoke(IAsyncResult 

result) 

   at 

Agilent.MassSpectrometry.DataAnalysis.Qualitative.QualForm.OnAsyncCallBack(IAsyncResult 

asyncResult) 

Message: Error creating window handle. 

Stack Trace:    at System.Windows.Forms.NativeWindow.CreateHandle(CreateParams cp) 

   at System.Windows.Forms.Control.CreateHandle() 

   at System.Windows.Forms.Control.get_Handle() 

   at System.Windows.Forms.Control.CreateGraphicsInternal() 

   at System.Windows.Forms.Control.CreateGraphics() 

   at 

Agilent.MassSpectrometry.DataAnalysis.Qualitative.BaseReportGenerator.WritePlotImageToFile(I

AppState appState, ExportedImageType imageType, UIUpdateDisplayPlotControlBase 

plotControl, Double heightByWidthRatio, String imageFilename) 

   at 

Agilent.MassSpectrometry.DataAnalysis.Qualitative.BaseReportGenerator.CreatePlotImageFile(ID

ataItem plotItem, ExportedImageType imageType, Boolean overlayPredictionPattern, IRange 

XZoomRange, Double heightByWidthRatio, Boolean allowZoom) 

   at 

Agilent.MassSpectrometry.DataAnalysis.Qualitative.BaseReportGenerator.WritePlotPairs(IDataIte

m[] plots, Int32 ItemID) 

   at 

Agilent.MassSpectrometry.DataAnalysis.Qualitative.CompoundReportGenerator.WriteCompound

Chromatograms(IDataItem plotItem, List`1 cpdChildren, Boolean& hasAllIonsResults) 
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   at 

Agilent.MassSpectrometry.DataAnalysis.Qualitative.CompoundReportGenerator.WriteCompounds

(IDataItem[] compounds) 

   at 

Agilent.MassSpectrometry.DataAnalysis.Qualitative.CompoundReportGenerator.GenerateReportS

pecialized(IDataItem[] selectedAnalysis) 

   at 

Agilent.MassSpectrometry.DataAnalysis.Qualitative.BaseReportGenerator.GenerateReportAndMa

pExceptions(IDataItem[] analyses) 

   at 

Agilent.MassSpectrometry.DataAnalysis.Qualitative.BaseReportGenerator.GenerateReport(IDataIt

em[] selectedAnalysis) 

   at Agilent.MassSpectrometry.DataAnalysis.Qualitative.CmdGenerateReport.DoSpecialized() 

   at Agilent.MassSpectrometry.DataAnalysis.Qualitative.QualCommandBase.Do() 

   at Agilent.MassSpectrometry.CommandModel.CommandHistory.Invoke(ICommand cmd) 

   at Agilent.MassSpectrometry.DataAnalysis.Qualitative.AppManager.Invoke(ICommand cmd) 

 

Issue # 196296 

 

Title Exception on generating Compound Report for ForensicsTox Find by Formula analysis 

Description When running reports on 1000's of compounds per multiple files, Excel stops and opens 

the Visual Basic debugger at a formatting statement. 

 

Issue # 196507 

 

Title Color coding of ions based on Fragment Anotation is still displayed when Fragment 

Anotation is unchecked 

Description Unchecking "Annotate Fragment Specturm Peaks with Formula" in "Method Editor: 

Generate Formula -> Fragment Formula" will cause the formulas to disappear but leave 

the ions that match the formulas colored. 

 

Issue # 196599 

 

Title All Ions: ?? appearing on "delete" and "extract complete result set". 

Description 1) Run All Ions FbF 

2) Select a compound 

3) Delete All fragment ion EIC objects (Right click delete on treeview) 

4) Extract complete result set 

5) Delete All fragment ion EICs objects (Right click delete on treeview) 

6) Extract complete result set. 

7) ?? will appear in the description 

 

Issue # 196720 

 

Title MS/MS Formula details disappear when selecting a different "Best" Formula after 

running Find Compounds by Auto MS/MS and MFG 

Description 1) Run Find Compounds by Auto MS/MS on "Sulfa-PosESIAutoMSMS-c.d", 

2) Run Generate Formula from Compounds.  

3) Select Compound 10 with m/z 311.0814 and look at MS/MS Formula Details 

window, which shows the fragment ion results.  

4) Select a different "Best" formula, and the MS/MS Formula Details window will 
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display "No Formula Results for this compound".  

 

Even changing the selection of "Best" back to the correct formula with the highest score 

will leave this window empty. 

 

Temporary Solution:  
The only way to recover the results in MS/MS Formula details is to rerun "Generate 

Formulas from Compounds".. 

 

Issue # 196721 

 

Title The "Hide Empty Columns" tool button in the Compound List works for the first level, 

but not the second level 

Description The "Hide Empty Columns" tool button in the Compound List works for the first level, 

but not the second level. 

 

This will not impact usability or stability. 

 

Issue # 196722 

 

Title Compound List column order for BioConfirm Protein Digest is randomly ordered. 

Description Opening any protein digest file will display compound list columns that are randomly 

ordered. 

 

Issue # 196831 

 

Title In Compound Details View, right-clicking near an axis in the Compound Chromatogram window 

will throw an error. 

Descrip

tion 

1. Generate compounds by performing FbF or MFE.  

2. Switch to Compound Details View (CDV) 

3. Right click on the gray area (of the x or y-axes, not on the plot directly) on the Compound 

Chromatogram Results window  

 

The following error is thrown: 

 

Program: Agilent MassHunter Workstation Software Qualitative Analysis B.06.00 

Build Configuration: Debug 

Message: Object reference not set to an instance of an object. 

Stack Trace:    at 

Agilent.MassSpectrometry.DataAnalysis.Qualitative.QualCpdChromPlotControl.ChromPlotMenu_

Opened(UIDisplayPlotContextMenuEventArgs ePlot) in 

z:\Archer\QualCommon\QualCommonUI\QualCommonUI\pspl_sources\QualCpdChromPlotControl

\QualCpdChromPlotControl_3.cs:line 764 

   at 

Agilent.MassSpectrometry.DataAnalysis.Qualitative.QualCpdChromPlotControl.UIComponent_Sho

wContextMenu(Object sender, UIDisplayContextMenuEventArgs e) in 

z:\Archer\QualCommon\QualCommonUI\QualCommonUI\pspl_sources\QualCpdChromPlotControl

\QualCpdChromPlotControl_3.cs:line 921. 

 

Issue # 196842 
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Title Merged Spectrum ID Results with LibSearch-MFG results - only the highest Lib Score 

hit has MFG results and Isotope pattern although all are labeled as merged LibSearch-

MFG. 

Description 1) Select ranges for the three largets peaks in the TIC  

2) Integrate & Extract Spectra -> Over Selected Ranges 

3) Highlight spectrum. 

4) Search unit mass library NIST11.L or Wiley9th.L for spectra from right-click menu 

in MS Spectrum Results 

5) Run "Generate Formula from Spectrum Peaks" 

6) Expand "Best merged hit - MFG results"  

 

Change "best" hit to another merged hit and expand it. 

There will be no MFG results. 

The MS Spectrum Results now do not include the Isotope Pattern 

 

Issue # 196930 

 

Title Spectrum not seen on printed report when grid lines are turned on. 

Description If grid lines are turned on, printing an analysis report for all compounds will not display 

the spectrum chromatograms in the User Spectra section. 

Only the mass labels will be visible. 

 

Temporary Solution:  
Turn off grid lines via plot options and then print. 

 

Issue # 196936 

 

Title A Compound report after running MFE + MFG contains 3 columns with the identical 

formula. 

Description 1) Run MFE and then "Generate formulas from compounds" 

2) Print the default compound report and the compound list contains three columns with 

the titles "Formula", "MFG Formula" and "DB Formula", which will all list the same 

formula (best hit for each compound). 

 

Temporary Solution:  
Create a specific report layout for MFE+MFG and only include the appropriate column. 

 

Issue # 196939 

 

Title When run as a Compound Automation Step, Find Compounds by MRM produces a 

TIC Scan with NO DATA POINTS. 

Description This occurs on any MRM or DMRM data file when Find Compounds by MRM is run 

via Compound Automation. 

 

Temporary Solution:  
Run Find Compounds by MRM manually. 

 

Issue # 197052 

 

Title Qual crashes when Find by Protein Deconvolution is attempted under specific 

conditions 
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Description 1) Open BioConfirmIntactProtein-default.m method.  

2) OpenBetaLac and BGALA data sets.  

3) In Find by Protein Deconvolution method editor, select "Pmod" as the algorithm. 

4) Enter 10000-150000 in Mass Range field 

5) Select Extract EIC and BPC in the Results tab 

6) Select "Universal" as integrator in the Find by Protein Deconvolution method editor.   

7) Select Actions -> Find by Protein Deconvolution.  

 

This causes Qual to crash.. 

 

Issue # 197054 

 

Title Protein compound report with two data sets may fail 

Description 1) Open BioConfirmIntactProtein-default.m method.  

2) Open BetaLac and BGALA data sets.   

3) In Find by Protein Deconvolution method editor Enter 10000-150000 in Mass Range 

field 

4) Select "Use limited m/z range" and "Unspecified" for Isotope width.   

5) Select Extract EIC in the Results tab. 

6) Select Actions -> Find by Protein Deconvolution.  

7) Select File -> Print -> Compound Report.   

8) Select All results, and Separate report per data file,  

9) Print preview in the Print Comp Rep dialog and click OK.   

 

Only one report gets produced and after that it generates error. 

 

NOTE: This MAY happen sporadically. 

 

Issue # 197064 

 

Title Compound Details View (CDV) - Exception when trying to access the Add/Remove Columns 

dialog in the 4th level of the Compound ID Results Window 

Descripti

on 

 In the Compound Details View (CDV), after running MFE + Sequence Match for BioConfirm, 

and then trying to access the Add/Remove Columns dialog in the 4th level of the Compound ID 

Results Window, the user is getting the following exception: 

 

Build Configuration: Release 

Message: Object reference not set to an instance of an object. 

Stack Trace:    at 

Agilent.MassSpectrometry.DataAnalysis.Qualitative.SelectCompoundColumnDialog..ctor(IResult

AttributeDefinitions definition) 

   at 

Agilent.MassSpectrometry.DataAnalysis.Qualitative.QualForm.AddRemoveColumnsMenuItems_

Click(Object sender, ToolClickEventArgs e) in 

t:\Archer\qual\presentation\AgtQual\QualFormP5ViewMenus.cs:line 5176 

   at 

Agilent.MassSpectrometry.DataAnalysis.Qualitative.QualForm.UltraToolbarsManager1_ToolClic

k(Object sender, ToolClickEventArgs e) in 

t:\Archer\qual\presentation\AgtQual\QualFormP6MenuStates.cs:line 2128 

 

Clicking OK on this error message will NOT crash Qual. 
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Issue # 197212 

 

Title Tooltip of Method Explorer is not properly updated 

Description 1) Launch Qual 

2) Hover over the Method Explorer pane: it should display the last name of the last 

method loaded. 

3) Open new method and check the tooltip of Method Explorer. The tooltip still 

displays the previous method's name. 

 

This has no impact on usability. 

 

Issue # 197263 

 

Title Annotation does not work properly for a HighE spectrum 

Description  In the MS Spectrum Results window, annotation does not work properly if the 

spectrum is a HighE spectrum. 

  

1) Find compounds by formula an an All Ions data file. 

2) Add an annotation to the peak at 920 for compound 3 (Crimidine) in the HighE Scan. 

 

- Cannot zoom into the baseline. 

- Can add an annotation, but cannot double-click on the annotation to show the 

annotation dialog box.  

- Right-click the annotation; can click the Annotation Properties menu item, but the 

annotation dialog box is not opened. 

- The toolbar buttons are all greyed out. 

- The menu items to "Select All Annotations", "Delete Selected Annotations", and 

"Delete All Annotations" are all greyed out. 

 

Issue # 197273 

 

Title Formula and Mass Calculators do not contain GC/Q-TOF parameters when a GC/Q-

TOF method is loaded 

Description When a GC/Q-TOF method is loaded, both the mass and formula calculator tools have 

the "H" selected instead of an electron.  

 

Additionally, the formula calculator has "even electron" selected in "MS ion electron 

state" instead of "allow both even and odd." 

 

Issue # 197404 

 

Title Chemical Data Dictionary Editor tabs do not display the relevant help topics 

Description Opening: Sequence -> Chemical Data Dictionary Editor and then pressing F1 will not 

display that specific tab's relevant help topic. 

Instead, the help topic displayed is for the Chemical Data Dictionary Editor dialog box. 

 

Issue # 197514 

 

Title Wizard pages do not display relevant help topics 

Description All options in the Wizard menu item do not properly display their relevant help topics 
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when the F1 key is pressed. 

  

Issue #  

 

Title  

Description  

 

 

 
Appendix A.  Glossary 
 

Term / Acronym Definition 

UI User Interface.  The visual representation of the software with which a user interacts. 

 


